Issues Syncing New Google Play Subaccounts
Incident Report for Appfigures
Resolved
All impacted Google accounts continue to remain stable after our fix. We're confident they'll remain so going over as well.
Posted Sep 20, 2021 - 17:40 EDT
Monitoring
We've rolled out a fix to correct the trouble for impacted Google accounts. For now, we'll keep an eye out for specific use cases and resolve after monitoring with more time.
Posted Sep 20, 2021 - 13:37 EDT
Identified
We've identified an issue impacting syncs across a handful of Google Play accounts. As a result, you may run into trouble when attempting to sync a new Google Play account or re-linking an existing account.

The integration team is working to resolve this as quickly as possible. We will look to share updates as they become available.
Posted Sep 20, 2021 - 11:55 EDT
This incident affected: Google Play (Downloads, Revenue).