Delays with Google's Reports
Incident Report for Appfigures
Resolved
Google's reports have caught up and are now available up to and including May 6th. As Google works with a standard delay of two to three days, the current availability of reports are within the known period so we're resolving this one.

Reach out to support for a closer look if your reports are not yet available up to the 6th.
Posted May 09, 2022 - 08:45 EDT
Update
Google released additional reports for May, with data for free apps now available up to and including May 3rd. We'll be syncing for all available accounts to bring in recent days.
Posted May 06, 2022 - 17:33 EDT
Update
Google released a new batch of reports where data is now available for all of April. May is still behind with reports, for free app downloads, as those continue to be delayed.

We'll continue to monitor until May reports are released!
Posted May 06, 2022 - 09:17 EDT
Update
Reports from Google remain delayed, where the latest report available still stands at April 20th. We continue to monitor the delay from Google and hope reports for following days will be released soon. As always, we'll import reports as soon as they are detected.
Posted May 03, 2022 - 09:48 EDT
Update
Google delays continue with reports, for free apps, as the latest report available for importing remains at April 20th. As soon as additional reports are released we will import for all.
Posted Apr 29, 2022 - 08:15 EDT
Update
Reports after the 20th are still delayed from Google. We'll continue to keep an eye on the growing delay until additional reports are released.
Posted Apr 27, 2022 - 17:53 EDT
Monitoring
Google's reports for free apps/products are delayed after the 20th of April. While Google tends to release these reports with a usual two to three day delay, this current delay of five days is longer than expected so we wanted to share the news.

As soon as Google releases any reports after the 20th we'll automatically import those for all accounts.
Posted Apr 26, 2022 - 12:38 EDT
This incident affected: Google Play (Downloads).