Google ranks delays
Incident Report for Appfigures
Resolved
Based on changes release by Google, beginning in March, Google reports on ranks for the top 600 apps only where in the past we could import the top 1500 ranks. This is the behavior we expect to continue going forward for countries/categories.
Posted Mar 19, 2021 - 12:13 EDT
Identified
We've identified the issue impacting delayed Google ranks and are working to bring these back up to full functionality as soon as possible.
Posted Mar 03, 2021 - 10:30 EST
Investigating
We're investigating delays with Google ranks beginning around 10pm EST.
Posted Mar 03, 2021 - 08:23 EST
This incident affected: Google Play (Ranks).