Google Play Regenerating Subscriptions
Incident Report for Appfigures
Resolved
Good news - we've completed the process to fully re-import Google subscriptions back to August 2020.

To ensure you have the most up to date numbers, we recommend you go back over your subscriptions data between August 2020 and November 2021 as they may have changed.
Posted Nov 15, 2021 - 20:00 EST
Update
We're currently re-importing Google's regenerated subscriptions reports, back to August of 2020.

Once all accounts have been re-synced we'll share a message here so you can check out any changes to your subscriptions data.
Posted Nov 03, 2021 - 15:00 EDT
Identified
After a thorough investigation we've determined that Google Play is regenerating their subscription reports between August 2020 through October 2021.

With corrected reports providing increased numbers for Active Subscriptions, Activations, and Cancellations, we'll be working to re-import all of Google's subscription reports back to August, once the updated reports are completely rolled out.
Posted Oct 19, 2021 - 21:00 EDT
This incident affected: Google Play (Subscriptions).