Windows Imports Delayed
Incident Report for Appfigures
Resolved
This issue is resolved and Windows imports have fully resumed. We'll continue monitoring this going forward.
Posted Feb 19, 2024 - 17:05 EST
Identified
Windows imports are delayed this morning. We've identified the issue and are rolling out a fix.
Posted Feb 19, 2024 - 12:14 EST
This incident affected: Windows Store (Sales).