Google Downloads Delays After December 3rd
Incident Report for Appfigures
Resolved
Google has released additional days of data, up to and including December 10th.
Posted Dec 13, 2023 - 09:56 EST
Monitoring
Google's reports for free apps are unavailable after December 3rd. Google's standard practice is to release data with a two to three day delay, with the current delay being closer to a week we are monitoring a bit more closely.

Once reports are generated with data for the 4th and on we'll automatically grab those for all.
Posted Dec 11, 2023 - 11:24 EST
This incident affected: Google Play (Downloads).