Updating the Google AdWords Integration

Incident Report for Appfigures

Resolved

Our update to Google's latest Ads API version is now complete, and Google Ads syncs are back up and running normally.

We've been monitoring the migration for the past 24 hours and everything is looking good.
Posted Jun 19, 2026 - 08:41 EDT

Identified

We're updating our Google Ads integration to support Google's latest API version.

While we're making the switch, some accounts may see delayed syncs or slower-than-usual updates. We're actively working through the migration and expect everything to be back to normal soon.
Posted Jun 17, 2026 - 20:56 EDT
This incident affected: AdWords.