Google's Missing Data for February 29th
Incident Report for Appfigures
Resolved
Google corrected monthly reports for February so data for the 29th is now available within the reports. We've automatically grabbed data for the day with daily imports.

If you're still seeing missing downloads data for the 29th reach out to the support team for a closer look.
Posted Mar 08, 2024 - 10:41 EST
Update
Google is looking into the missing data for the 29th. As we know more we'll share the most up to date info here.
Posted Mar 06, 2024 - 16:19 EST
Identified
We've detected that Google has not released data, for free apps, for February 29th despite data for March 1st and 2nd having already been released.

We'll reach out to Google in hopes of getting the February report corrected as soon as possible. Once reports are regenerated we'll re-import for everyone.
Posted Mar 05, 2024 - 10:31 EST
This incident affected: Google Play (Downloads).