Data delays for free Google apps after January 17th
Incident Report for Appfigures
Resolved
Google has (finally) released reports after the 17th! Reports are now available up to and including January 26th.
Posted Jan 29, 2024 - 16:56 EST
Update
We're still waiting for reports after the 17th to be released for free apps. Google is investigating the delay on their end.
Posted Jan 26, 2024 - 10:05 EST
Update
January 17th continues to be the latest data available within Google's reports. We'll continue to monitor until additional days are released.
Posted Jan 25, 2024 - 09:38 EST
Monitoring
Google is behind schedule with releasing sales data as the latest date available in reports, for free apps, is January 17th. Downloads are not available for any dates after the 17th. As soon as any reports after the 17th are released we'll automatically import those for everyone.

Data for paid products is up to date with the latest date available being January 23rd. Full subscriptions data has been released up to the 21st and partial data for the 22nd.
Posted Jan 24, 2024 - 12:48 EST
This incident affected: Google Play (Downloads).