Google's latest report for paid products is March 13th

Incident Report for Appfigures

Resolved

Good news - Google has released paid data for the 14th and on! Daily syncs have automatically picked up on the new dates for reporting.
Posted Mar 19, 2025 - 09:49 EDT

Update

Google has confirmed they are investigating the data delay after March 13th. We'll automatically import additional days as soon as they're available in reports.
Posted Mar 18, 2025 - 11:07 EDT

Monitoring

We're still waiting for Google to release paid data after the 13th. We'll continue to monitor the delay until then.
Posted Mar 17, 2025 - 10:28 EDT

Identified

Google is unusually delayed in releasing reports for paid products, with the most recent date being March 13th.

If you check out Google's developer console through Download reports > Statistics > Estimated > 2025 > March, you'll see a message from Google that says, "This report includes data up to March 13th, 2025."

We'll automatically import data as Google releases additional dates.
Posted Mar 16, 2025 - 19:02 EDT
This incident affected: Google Play (Revenue).