Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 30, 2024 - 19:00 EDT
Scheduled
We will be performing some additional upgrades to our reviews import and search infrastructure. In this three-hour window you will continue to be able to search and see your existing reviews but new and updated reviews won't be collected. We'll automatically import any reviews that were added or updated during the window when the upgrades are complete.
Posted Oct 30, 2024 - 12:11 EDT
This scheduled maintenance affected: Steam (Reviews), Amazon (Reviews), Windows Store (Reviews), Apple (Reviews), and Google Play (Reviews).