ASO Keyword Performance Delays
Incident Report for Appfigures
Resolved
As we've continued to monitor throughout the day, we're confidentially resolving this one as everything is back to normal.
Posted Mar 03, 2021 - 17:22 EST
Update
Google, along with Apple, is now as up to date as possible and will continue to import as expected going forward. We'll continue to monitor on our end for a while longer to be safe.
Posted Mar 03, 2021 - 10:30 EST
Monitoring
Apple keywords ranks are back up to speed and we will monitor going forward.

We're still working on speeding up Google keyword ranks and will continue to work on this until resolved.
Posted Mar 03, 2021 - 10:00 EST
Identified
We've identified the issue that's causing issues with ASO delays and are working to resolve this for both stores as quickly as possible.
Posted Mar 03, 2021 - 08:42 EST
Investigating
We're investigating an issue causing ASO keyword ranks to be delayed for both Apple and Google.
Posted Mar 03, 2021 - 06:45 EST
This incident affected: ASO.