Investigating Issues Replying to Apple Reviews

Incident Report for Appfigures

Monitoring

Apple issues continue, but remain sporadic when replying to Apple reviews. We’ll continue to monitor the situation from our end.
Posted Oct 23, 2025 - 18:03 EDT

Investigating

We’re investigating inconsistencies from Apple that are affecting the experience of replying to reviews.

At this time, replies are still being created successfully, but you might see error messages suggesting the reply didn’t go through - even though it actually did.

We’re working to understand what’s causing these inconsistencies and will share updates as soon as we know more.
Posted Oct 23, 2025 - 11:59 EDT
This incident affects: Apple (Reviews).